<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US" xml:lang="en-US">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" /><title>New Curry Pizza House Opens in Natomas | The Natomas Buzz</title>

<meta name="description" content="STAFF REPORT THE NATOMAS BUZZ | @natomasbuzz California-based Curry Pizza House is expanding with a location in Natomas. The new pizzeria occupies a renovated space where California Express Pizza opened in 2021 and operated for about a year. A grand-opening ribbon cutting event is set for 11 a.m. tomorrow, May 5 with the Natomas Chamber" />
<meta name="robots" content="max-image-preview:large" />
<meta name="keywords" content="business,minority owned business,restaurants,eateries" />
<script src="/cdn-cgi/apps/head/v3BnpADM3qgexlJ9PYR3eG7EkHg.js"></script><link rel="canonical" href="https://www.natomasbuzz.com/2022/05/new-curry-pizza-house-opens-in-natomas/" />
<script type="application/ld+json" class="aioseo-schema">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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Natomas Buzz &raquo; Feed" href="https://feeds.feedburner.com/TheNatomasBuzz" />
<link rel="alternate" type="application/rss+xml" title="The Natomas Buzz &raquo; Comments Feed" href="https://www.natomasbuzz.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Natomas Buzz &raquo; New Curry Pizza House Opens in Natomas Comments Feed" href="https://www.natomasbuzz.com/2022/05/new-curry-pizza-house-opens-in-natomas/feed/" />

<script src="//www.googletagmanager.com/gtag/js?id=UA-3361382-2" data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>

<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.natomasbuzz.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=148c2183e3f7a8eec23d2367ee517a32"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='news-theme-css' href='https://www.natomasbuzz.com/wp-content/themes/news/style.css?ver=2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.natomasbuzz.com/wp-includes/css/dist/block-library/style.min.css?ver=148c2183e3f7a8eec23d2367ee517a32' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='dashicons-css' href='https://www.natomasbuzz.com/wp-includes/css/dashicons.min.css?ver=148c2183e3f7a8eec23d2367ee517a32' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css' href='https://www.natomasbuzz.com/wp-content/plugins/post-views-counter/css/frontend.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='add_google_fonts-css' href='https://fonts.googleapis.com/css?family=Oswald%7CDroid+Sans&#038;display=swap&#038;ver=148c2183e3f7a8eec23d2367ee517a32' type='text/css' media='all' />
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.5.1' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.natomasbuzz.com","hash_tracking":"false","ua":"UA-3361382-2","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3' id='html5shiv-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://www.natomasbuzz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.natomasbuzz.com/wp-json/wp/v2/posts/29117" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.natomasbuzz.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.natomasbuzz.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.natomasbuzz.com/?p=29117' />
<link rel="alternate" type="application/json+oembed" href="https://www.natomasbuzz.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.natomasbuzz.com%2F2022%2F05%2Fnew-curry-pizza-house-opens-in-natomas%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.natomasbuzz.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.natomasbuzz.com%2F2022%2F05%2Fnew-curry-pizza-house-opens-in-natomas%2F&#038;format=xml" />
<link rel="icon" href="https://www.natomasbuzz.com/favicon.ico" />
<link rel="pingback" href="https://www.natomasbuzz.com/xmlrpc.php" />
<style type="text/css">#header { background: url(https://www.natomasbuzz.com/wp-content/uploads/2013/06/NatomasBuzzMasthead1000.jpg) no-repeat !important; }</style>
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>

<style>
			#wp-admin-bar-pvc-post-views .pvc-graph-container { padding-top: 6px; padding-bottom: 6px; position: relative; display: block; height: 100%; box-sizing: border-box; }
			#wp-admin-bar-pvc-post-views .pvc-line-graph {
				display: inline-block;
				width: 1px;
				margin-right: 1px;
				background-color: #ccc;
				vertical-align: baseline;
			}
			#wp-admin-bar-pvc-post-views .pvc-line-graph:hover { background-color: #eee; }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-0 { height: 1% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-1 { height: 5% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-2 { height: 10% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-3 { height: 15% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-4 { height: 20% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-5 { height: 25% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-6 { height: 30% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-7 { height: 35% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-8 { height: 40% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-9 { height: 45% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-10 { height: 50% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-11 { height: 55% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-12 { height: 60% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-13 { height: 65% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-14 { height: 70% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-15 { height: 75% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-16 { height: 80% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-17 { height: 85% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-18 { height: 90% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-19 { height: 95% }
			#wp-admin-bar-pvc-post-views .pvc-line-graph-20 { height: 100% }
		</style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-29117 single-format-standard custom-header header-image content-sidebar"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div id="top-banner">
</div><div id="subnav"><div class="wrap"><ul id="menu-top-menu" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-4718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4718"><a href="/">Home</a></li>
<li id="menu-item-3630" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3630"><a href="https://www.natomasbuzz.com/about/">About</a></li>
<li id="menu-item-20621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20621"><a href="https://www.natomasbuzz.com/advertise/">Advertise</a></li>
<li id="menu-item-25351" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25351"><a href="https://www.natomasbuzz.com/business-directory/">Business Directory</a></li>
<li id="menu-item-3848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3848"><a href="https://www.natomasbuzz.com/comment/">Comment Policy</a></li>
<li id="menu-item-3629" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3629"><a href="https://www.natomasbuzz.com/contact/">Contact Us</a></li>
<li id="menu-item-20716" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20716"><a href="https://www.natomasbuzz.com/press/">Press</a></li>
<li id="menu-item-20713" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-20713"><a href="https://www.natomasbuzz.com/privacy-policy/">Privacy Policy</a></li>
</ul></div></div><div id="header-search-bar">
<form class="searchform search-form" action="https://www.natomasbuzz.com/" method="get">
<input class="s search-input" type="text" onblur="if (this.value == '') {this.value = 'Search this website…';}" onfocus="if (this.value == 'Search this website…') {this.value = '';}" name="s" value="Search this website…">
<input class="searchsubmit search-submit" type="submit" value="Search">
</form>
</div><div id="wrap"><div id="header"><div class="wrap"><div id="title-area"><p id="title"><a href="https://www.natomasbuzz.com/">The Natomas Buzz</a></p><p id="description">Natomas News &amp; Information</p></div><div class="widget-area header-widget-area"><div id="custom_html-26" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1314"></broadstreet-zone></div></div></div>
<div id="custom_html-23" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><script src="https://cdn.broadstreetads.com/init-2.min.js"></script>
<script>broadstreet.watch({ networkId: 484 })</script></div></div></div>
</div></div></div><div id="nav"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-21489" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21489"><a href="https://www.natomasbuzz.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-20675" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20675"><a href="https://www.natomasbuzz.com/community-calendar/">Calendar</a></li>
<li id="menu-item-20720" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20720"><a href="https://www.natomasbuzz.com/cops/">Cops Log</a></li>
<li id="menu-item-20714" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20714"><a href="https://www.natomasbuzz.com/links/">Links</a></li>
<li id="menu-item-25508" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25508"><a href="https://www.natomasbuzz.com/category/obituary/">Obituaries</a></li>
<li id="menu-item-27301" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27301"><a href="https://www.natomasbuzz.com/road-closures/">Roads</a></li>
<li id="menu-item-18818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18818"><a href="https://www.natomasbuzz.com/2011/10/streetwise-a-special-report/">Projects</a></li>
<li id="menu-item-20851" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20851"><a href="https://www.natomasbuzz.com/support-local-journalism-become-a-subscriber/">Support Us</a></li>
<li id="menu-item-20888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20888"><a href="https://www.natomasbuzz.com/worship/">Worship</a></li>
<li class="right date">May 9, 2022</li></ul></div></div><div id="inner"><div class="wrap"><div id="masthead-banner">
<div id="custom_html-22" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1315"></broadstreet-zone></div></div></div></div><div id="content-sidebar-wrap"><div id="content" class="hfeed"><div class="breadcrumb">You are here: <a href="https://www.natomasbuzz.com/"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a> <span aria-label="breadcrumb separator">/</span> <a href="https://www.natomasbuzz.com/category/eateries/"><span class="breadcrumb-link-text-wrap" itemprop="name">eateries</span></a> <span aria-label="breadcrumb separator">/</span> New Curry Pizza House Opens in Natomas</div><div class="post-29117 post type-post status-publish format-standard has-post-thumbnail hentry category-eateries tag-business tag-minority-owned-business tag-restaurants entry"><h1 class="entry-title">New Curry Pizza House Opens in Natomas</h1>
<div class="post-info"><span class="date published time" title="2022-05-04T12:36:07-07:00">May 4, 2022</span> by <span class="author vcard"><span class="fn"><a href="https://www.natomasbuzz.com/author/bboyd/" rel="author">bboyd</a></span></span> <span class="post-comments"><a href="https://www.natomasbuzz.com/2022/05/new-curry-pizza-house-opens-in-natomas/#respond">Leave a Comment</a></span> </div><div class="entry-content"><p><strong>STAFF REPORT<br />
<em>THE NATOMAS BUZZ</em> | @natomasbuzz</strong></p>
<p><a href="https://www.natomasbuzz.com/wp-content/uploads/2022/05/4-may-2022-curry-pizza-house-1.jpg"><img class="alignright wp-image-29126 size-medium" src="https://www.natomasbuzz.com/wp-content/uploads/2022/05/4-may-2022-curry-pizza-house-1-282x300.jpg" alt="" width="282" height="300" srcset="https://www.natomasbuzz.com/wp-content/uploads/2022/05/4-may-2022-curry-pizza-house-1-282x300.jpg 282w, https://www.natomasbuzz.com/wp-content/uploads/2022/05/4-may-2022-curry-pizza-house-1-964x1024.jpg 964w, https://www.natomasbuzz.com/wp-content/uploads/2022/05/4-may-2022-curry-pizza-house-1-768x816.jpg 768w, https://www.natomasbuzz.com/wp-content/uploads/2022/05/4-may-2022-curry-pizza-house-1.jpg 1400w" sizes="(max-width: 282px) 100vw, 282px" /></a>California-based Curry Pizza House is expanding with a location in Natomas.</p>
<p>The new pizzeria occupies a renovated space <a href="https://www.natomasbuzz.com/2021/01/california-express-pizza-expanding-to-natomas/" target="_blank" rel="noopener">where California Express Pizza opened in 2021 and operated for about a year</a>.</p>
<p>A grand-opening ribbon cutting event is set for 11 a.m. tomorrow, May 5 with the Natomas Chamber of Commerce. The first 10 customers will receive a free, small pizza and orders will be 50 percent off on May 5, 2022.</p>
<p>&#8220;Curry Pizza House has been such a success throughout California and Texas that we couldn&#8217;t wait to expand to California&#8217;s state capital,&#8221; Gursewak Gill, Curry Pizza House founder, said in the release. &#8220;Natomas was a natural choice for our franchising partner because he saw the potential for Curry Pizza House to serve as a community hub that brings novel flavor combinations to the area.&#8221;</p>
<p>Curry Pizza House was founded in 2012 in Fremont, Calif. There are several locations in California including one in Roseville, according to the company&#8217;s website.</p>
<p>The Curry Pizza House menu features spices and traditional Indian flavors. Some notable offerings include Curry Chicken Masala Pizza with curry sauce, cheese and vegetables; Palak Paneer Pizza which combines pesto sauce with masala paneer, ginger and garlic; and Aloo Chaat Pizza made with house red sauce and marinated potatoes.</p>
<p>The menu also has more traditional pizza options, vegetarian pizzas and gluten-free and cauliflower crust alternatives.  Wings marinated in curries and spices and mango lassi round out the &#8220;fresh and spicy&#8221; offerings.</p>
<p>The new Curry House Pizza is located at 4261 Truxel Road in Suite A6. It is open 11 a.m. to 9 p.m. daily.</p>
<p><a href="https://www.paypal.com/donate/?hosted_button_id=3DL92R4H2XWFN"><img loading="lazy" class="aligncenter size-full wp-image-20853" src="https://www.natomasbuzz.com/wp-content/uploads/2019/12/Support-Our-Journalism-1.png" alt="" width="180" height="75" /></a></p>
<div class="post-views post-29117 entry-meta">
<span class="post-views-icon dashicons dashicons-chart-bar"></span>
<span class="post-views-label">Post Views:</span>
<span class="post-views-count">967</span>
</div>
</div><div class="post-meta"><span class="categories">Filed Under: <a href="https://www.natomasbuzz.com/category/eateries/" rel="category tag">eateries</a></span> <span class="tags">Tagged With: <a href="https://www.natomasbuzz.com/tag/business/" rel="tag">business</a>, <a href="https://www.natomasbuzz.com/tag/minority-owned-business/" rel="tag">minority owned business</a>, <a href="https://www.natomasbuzz.com/tag/restaurants/" rel="tag">restaurants</a></span></div><div id="prev-next">
<div class="prev-link">&larr; Previous Post
<a href="https://www.natomasbuzz.com/2022/04/in-memoriam-elsie-leona-coke-byrd/" rel="prev">In Memoriam: Elsie Leona (Coke) Byrd</a></div>
<div class="next-link">Next Post &rarr;
<a href="https://www.natomasbuzz.com/2022/05/new-covid-19-cases-see-uptick-in-natomas/" rel="next">New COVID-19 Cases See Uptick in Natomas</a></div>
</div>
</div> <div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Speak Your Mind <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/05/new-curry-pizza-house-opens-in-natomas/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://www.natomasbuzz.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.natomasbuzz.com%2F2022%2F05%2Fnew-curry-pizza-house-opens-in-natomas%2F">logged in</a> to post a comment.</p> </div>
</div><div id="sidebar" class="sidebar widget-area"><div id="text-29" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us!</h4>
<div class="textwidget"><div class="socialmedia-buttons">
<a target="_blank" href="https://www.facebook.com/natomasbuzz" rel="noopener"><img width="32" height="32" title="Follow Us on Facebook" alt="Follow Us on Facebook" src="https://www.natomasbuzz.com/wp-content/themes/news/images/icons/facebook.png"></a>
<a target="_blank" href="https://twitter.com/natomasbuzz/" rel="noopener"><img width="32" height="32" title="Follow Us on Twitter" alt="Follow Us on Twitter" src="https://www.natomasbuzz.com/wp-content/themes/news/images/icons/twitter.png"></a>
<a target="_blank" href="https://instagram.com/thenatomasbuzz" rel="noopener"><img width="32" height="32" title="Follow Us on Instagram" alt="Follow Us on Instagram" src="https://www.natomasbuzz.com/wp-content/themes/news/images/icons/instagram.png"></a>
<a target="_blank" href="https://www.pinterest.com/natomasbuzz/" rel="noopener"><img width="32" height="32" title="Follow Us on Pinterest" alt="Follow Us on Pinterest" src="https://www.natomasbuzz.com/wp-content/themes/news/images/icons/pinterest.png"></a>
<a target="_blank" href="https://www.youtube.com/user/natomasbuzz" rel="noopener"><img width="32" height="32" title="Follow Us on YouTube" alt="Follow Us on YouTube" src="https://www.natomasbuzz.com/wp-content/themes/news/images/icons/youtube.png"></a>
</div></div>
</div></div>
<div id="custom_html-87" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-95" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-94" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-81" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-88" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-78" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-71" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-80" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-76" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-67" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-65" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-70" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-47" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-45" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-86" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="custom_html-44" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1312"></broadstreet-zone></div></div></div>
<div id="hello_tabs_widget-4" class="widget widget_hello_tabs_widget"><div class="widget-wrap"> <div id="tabsWrapper" style="display:none">
<div id="tabs" class="tabs ">
<div id="tabs-content" class="tabs-content">
<div id="tabs-content-inner" class="tabs-content-inner">
<div id="archives-4" style="height:auto;width:100%;"><div class=""><h2>Buzz Archives</h2> <label class="screen-reader-text" for="archives-dropdown-4">Buzz Archives</label>
<select id="archives-dropdown-4" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://www.natomasbuzz.com/2022/05/'> May 2022 &nbsp;(2)</option>
<option value='https://www.natomasbuzz.com/2022/04/'> April 2022 &nbsp;(6)</option>
<option value='https://www.natomasbuzz.com/2022/03/'> March 2022 &nbsp;(18)</option>
<option value='https://www.natomasbuzz.com/2022/02/'> February 2022 &nbsp;(22)</option>
<option value='https://www.natomasbuzz.com/2022/01/'> January 2022 &nbsp;(8)</option>
<option value='https://www.natomasbuzz.com/2021/12/'> December 2021 &nbsp;(10)</option>
<option value='https://www.natomasbuzz.com/2021/11/'> November 2021 &nbsp;(23)</option>
<option value='https://www.natomasbuzz.com/2021/10/'> October 2021 &nbsp;(16)</option>
<option value='https://www.natomasbuzz.com/2021/09/'> September 2021 &nbsp;(7)</option>
<option value='https://www.natomasbuzz.com/2021/08/'> August 2021 &nbsp;(20)</option>
<option value='https://www.natomasbuzz.com/2021/07/'> July 2021 &nbsp;(28)</option>
<option value='https://www.natomasbuzz.com/2021/06/'> June 2021 &nbsp;(20)</option>
<option value='https://www.natomasbuzz.com/2021/05/'> May 2021 &nbsp;(29)</option>
<option value='https://www.natomasbuzz.com/2021/04/'> April 2021 &nbsp;(25)</option>
<option value='https://www.natomasbuzz.com/2021/03/'> March 2021 &nbsp;(24)</option>
<option value='https://www.natomasbuzz.com/2021/02/'> February 2021 &nbsp;(19)</option>
<option value='https://www.natomasbuzz.com/2021/01/'> January 2021 &nbsp;(39)</option>
<option value='https://www.natomasbuzz.com/2020/12/'> December 2020 &nbsp;(14)</option>
<option value='https://www.natomasbuzz.com/2020/11/'> November 2020 &nbsp;(35)</option>
<option value='https://www.natomasbuzz.com/2020/10/'> October 2020 &nbsp;(32)</option>
<option value='https://www.natomasbuzz.com/2020/09/'> September 2020 &nbsp;(27)</option>
<option value='https://www.natomasbuzz.com/2020/08/'> August 2020 &nbsp;(17)</option>
<option value='https://www.natomasbuzz.com/2020/07/'> July 2020 &nbsp;(38)</option>
<option value='https://www.natomasbuzz.com/2020/06/'> June 2020 &nbsp;(32)</option>
<option value='https://www.natomasbuzz.com/2020/05/'> May 2020 &nbsp;(43)</option>
<option value='https://www.natomasbuzz.com/2020/04/'> April 2020 &nbsp;(21)</option>
<option value='https://www.natomasbuzz.com/2020/03/'> March 2020 &nbsp;(25)</option>
<option value='https://www.natomasbuzz.com/2020/02/'> February 2020 &nbsp;(12)</option>
<option value='https://www.natomasbuzz.com/2020/01/'> January 2020 &nbsp;(14)</option>
<option value='https://www.natomasbuzz.com/2019/12/'> December 2019 &nbsp;(11)</option>
<option value='https://www.natomasbuzz.com/2019/11/'> November 2019 &nbsp;(9)</option>
<option value='https://www.natomasbuzz.com/2019/04/'> April 2019 &nbsp;(3)</option>
<option value='https://www.natomasbuzz.com/2018/11/'> November 2018 &nbsp;(7)</option>
<option value='https://www.natomasbuzz.com/2018/10/'> October 2018 &nbsp;(10)</option>
<option value='https://www.natomasbuzz.com/2018/09/'> September 2018 &nbsp;(3)</option>
<option value='https://www.natomasbuzz.com/2017/08/'> August 2017 &nbsp;(1)</option>
<option value='https://www.natomasbuzz.com/2016/04/'> April 2016 &nbsp;(15)</option>
<option value='https://www.natomasbuzz.com/2016/03/'> March 2016 &nbsp;(1)</option>
<option value='https://www.natomasbuzz.com/2016/02/'> February 2016 &nbsp;(3)</option>
<option value='https://www.natomasbuzz.com/2016/01/'> January 2016 &nbsp;(27)</option>
<option value='https://www.natomasbuzz.com/2015/12/'> December 2015 &nbsp;(14)</option>
<option value='https://www.natomasbuzz.com/2015/11/'> November 2015 &nbsp;(17)</option>
<option value='https://www.natomasbuzz.com/2015/10/'> October 2015 &nbsp;(32)</option>
<option value='https://www.natomasbuzz.com/2015/09/'> September 2015 &nbsp;(20)</option>
<option value='https://www.natomasbuzz.com/2015/08/'> August 2015 &nbsp;(14)</option>
<option value='https://www.natomasbuzz.com/2015/07/'> July 2015 &nbsp;(26)</option>
<option value='https://www.natomasbuzz.com/2015/06/'> June 2015 &nbsp;(27)</option>
<option value='https://www.natomasbuzz.com/2015/05/'> May 2015 &nbsp;(23)</option>
<option value='https://www.natomasbuzz.com/2015/04/'> April 2015 &nbsp;(21)</option>
<option value='https://www.natomasbuzz.com/2015/03/'> March 2015 &nbsp;(35)</option>
<option value='https://www.natomasbuzz.com/2015/02/'> February 2015 &nbsp;(28)</option>
<option value='https://www.natomasbuzz.com/2015/01/'> January 2015 &nbsp;(8)</option>
<option value='https://www.natomasbuzz.com/2014/12/'> December 2014 &nbsp;(5)</option>
<option value='https://www.natomasbuzz.com/2014/11/'> November 2014 &nbsp;(27)</option>
<option value='https://www.natomasbuzz.com/2014/10/'> October 2014 &nbsp;(47)</option>
<option value='https://www.natomasbuzz.com/2014/09/'> September 2014 &nbsp;(21)</option>
<option value='https://www.natomasbuzz.com/2014/08/'> August 2014 &nbsp;(32)</option>
<option value='https://www.natomasbuzz.com/2014/07/'> July 2014 &nbsp;(6)</option>
<option value='https://www.natomasbuzz.com/2014/06/'> June 2014 &nbsp;(28)</option>
<option value='https://www.natomasbuzz.com/2014/05/'> May 2014 &nbsp;(45)</option>
<option value='https://www.natomasbuzz.com/2014/04/'> April 2014 &nbsp;(21)</option>
<option value='https://www.natomasbuzz.com/2014/03/'> March 2014 &nbsp;(23)</option>
<option value='https://www.natomasbuzz.com/2014/02/'> February 2014 &nbsp;(44)</option>
<option value='https://www.natomasbuzz.com/2014/01/'> January 2014 &nbsp;(36)</option>
<option value='https://www.natomasbuzz.com/2013/12/'> December 2013 &nbsp;(28)</option>
<option value='https://www.natomasbuzz.com/2013/11/'> November 2013 &nbsp;(46)</option>
<option value='https://www.natomasbuzz.com/2013/10/'> October 2013 &nbsp;(61)</option>
<option value='https://www.natomasbuzz.com/2013/09/'> September 2013 &nbsp;(25)</option>
<option value='https://www.natomasbuzz.com/2013/08/'> August 2013 &nbsp;(25)</option>
<option value='https://www.natomasbuzz.com/2013/07/'> July 2013 &nbsp;(50)</option>
<option value='https://www.natomasbuzz.com/2013/06/'> June 2013 &nbsp;(76)</option>
<option value='https://www.natomasbuzz.com/2013/05/'> May 2013 &nbsp;(56)</option>
<option value='https://www.natomasbuzz.com/2013/04/'> April 2013 &nbsp;(75)</option>
<option value='https://www.natomasbuzz.com/2013/03/'> March 2013 &nbsp;(37)</option>
<option value='https://www.natomasbuzz.com/2013/02/'> February 2013 &nbsp;(69)</option>
<option value='https://www.natomasbuzz.com/2013/01/'> January 2013 &nbsp;(57)</option>
<option value='https://www.natomasbuzz.com/2012/12/'> December 2012 &nbsp;(64)</option>
<option value='https://www.natomasbuzz.com/2012/11/'> November 2012 &nbsp;(42)</option>
<option value='https://www.natomasbuzz.com/2012/10/'> October 2012 &nbsp;(56)</option>
<option value='https://www.natomasbuzz.com/2012/09/'> September 2012 &nbsp;(58)</option>
<option value='https://www.natomasbuzz.com/2012/08/'> August 2012 &nbsp;(41)</option>
<option value='https://www.natomasbuzz.com/2012/07/'> July 2012 &nbsp;(41)</option>
<option value='https://www.natomasbuzz.com/2012/06/'> June 2012 &nbsp;(38)</option>
<option value='https://www.natomasbuzz.com/2012/05/'> May 2012 &nbsp;(50)</option>
<option value='https://www.natomasbuzz.com/2012/04/'> April 2012 &nbsp;(44)</option>
<option value='https://www.natomasbuzz.com/2012/03/'> March 2012 &nbsp;(56)</option>
<option value='https://www.natomasbuzz.com/2012/02/'> February 2012 &nbsp;(68)</option>
<option value='https://www.natomasbuzz.com/2012/01/'> January 2012 &nbsp;(49)</option>
<option value='https://www.natomasbuzz.com/2011/12/'> December 2011 &nbsp;(33)</option>
<option value='https://www.natomasbuzz.com/2011/11/'> November 2011 &nbsp;(62)</option>
<option value='https://www.natomasbuzz.com/2011/10/'> October 2011 &nbsp;(87)</option>
<option value='https://www.natomasbuzz.com/2011/09/'> September 2011 &nbsp;(56)</option>
<option value='https://www.natomasbuzz.com/2011/08/'> August 2011 &nbsp;(51)</option>
<option value='https://www.natomasbuzz.com/2011/07/'> July 2011 &nbsp;(63)</option>
<option value='https://www.natomasbuzz.com/2011/06/'> June 2011 &nbsp;(55)</option>
<option value='https://www.natomasbuzz.com/2011/05/'> May 2011 &nbsp;(36)</option>
<option value='https://www.natomasbuzz.com/2011/04/'> April 2011 &nbsp;(24)</option>
<option value='https://www.natomasbuzz.com/2011/03/'> March 2011 &nbsp;(38)</option>
<option value='https://www.natomasbuzz.com/2011/02/'> February 2011 &nbsp;(31)</option>
<option value='https://www.natomasbuzz.com/2011/01/'> January 2011 &nbsp;(50)</option>
<option value='https://www.natomasbuzz.com/2010/12/'> December 2010 &nbsp;(43)</option>
<option value='https://www.natomasbuzz.com/2010/11/'> November 2010 &nbsp;(35)</option>
<option value='https://www.natomasbuzz.com/2010/10/'> October 2010 &nbsp;(48)</option>
<option value='https://www.natomasbuzz.com/2010/09/'> September 2010 &nbsp;(76)</option>
<option value='https://www.natomasbuzz.com/2010/08/'> August 2010 &nbsp;(69)</option>
<option value='https://www.natomasbuzz.com/2010/07/'> July 2010 &nbsp;(52)</option>
<option value='https://www.natomasbuzz.com/2010/06/'> June 2010 &nbsp;(64)</option>
<option value='https://www.natomasbuzz.com/2010/05/'> May 2010 &nbsp;(45)</option>
<option value='https://www.natomasbuzz.com/2010/04/'> April 2010 &nbsp;(64)</option>
<option value='https://www.natomasbuzz.com/2010/03/'> March 2010 &nbsp;(55)</option>
<option value='https://www.natomasbuzz.com/2010/02/'> February 2010 &nbsp;(46)</option>
<option value='https://www.natomasbuzz.com/2010/01/'> January 2010 &nbsp;(38)</option>
<option value='https://www.natomasbuzz.com/2009/12/'> December 2009 &nbsp;(39)</option>
<option value='https://www.natomasbuzz.com/2009/11/'> November 2009 &nbsp;(48)</option>
<option value='https://www.natomasbuzz.com/2009/10/'> October 2009 &nbsp;(73)</option>
<option value='https://www.natomasbuzz.com/2009/09/'> September 2009 &nbsp;(70)</option>
<option value='https://www.natomasbuzz.com/2009/08/'> August 2009 &nbsp;(50)</option>
<option value='https://www.natomasbuzz.com/2009/07/'> July 2009 &nbsp;(78)</option>
<option value='https://www.natomasbuzz.com/2009/06/'> June 2009 &nbsp;(66)</option>
<option value='https://www.natomasbuzz.com/2009/05/'> May 2009 &nbsp;(78)</option>
<option value='https://www.natomasbuzz.com/2009/04/'> April 2009 &nbsp;(89)</option>
<option value='https://www.natomasbuzz.com/2009/03/'> March 2009 &nbsp;(93)</option>
<option value='https://www.natomasbuzz.com/2009/02/'> February 2009 &nbsp;(71)</option>
<option value='https://www.natomasbuzz.com/2009/01/'> January 2009 &nbsp;(56)</option>
<option value='https://www.natomasbuzz.com/2008/12/'> December 2008 &nbsp;(91)</option>
<option value='https://www.natomasbuzz.com/2008/11/'> November 2008 &nbsp;(77)</option>
<option value='https://www.natomasbuzz.com/2008/10/'> October 2008 &nbsp;(70)</option>
<option value='https://www.natomasbuzz.com/2008/09/'> September 2008 &nbsp;(52)</option>
<option value='https://www.natomasbuzz.com/2008/08/'> August 2008 &nbsp;(54)</option>
<option value='https://www.natomasbuzz.com/2008/07/'> July 2008 &nbsp;(78)</option>
<option value='https://www.natomasbuzz.com/2008/06/'> June 2008 &nbsp;(80)</option>
<option value='https://www.natomasbuzz.com/2008/05/'> May 2008 &nbsp;(73)</option>
<option value='https://www.natomasbuzz.com/2008/04/'> April 2008 &nbsp;(68)</option>
<option value='https://www.natomasbuzz.com/2008/03/'> March 2008 &nbsp;(57)</option>
<option value='https://www.natomasbuzz.com/2008/02/'> February 2008 &nbsp;(93)</option>
<option value='https://www.natomasbuzz.com/2008/01/'> January 2008 &nbsp;(83)</option>
<option value='https://www.natomasbuzz.com/2007/12/'> December 2007 &nbsp;(2)</option>
<option value='https://www.natomasbuzz.com/2007/11/'> November 2007 &nbsp;(1)</option>
<option value='https://www.natomasbuzz.com/2007/08/'> August 2007 &nbsp;(3)</option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-4" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div></div><div id="recent-comments-3" style="height:auto;width:100%;"><div class=""><h2>Comments</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='https://www.natomasbuzz.com/2022/05/new-curry-pizza-house-opens-in-natomas/' rel='external nofollow ugc' class='url'>New Curry Pizza House Opens in Natomas | The Natomas Buzz</a></span> on <a href="https://www.natomasbuzz.com/2021/01/california-express-pizza-expanding-to-natomas/#comment-7424">California Express Pizza Expanding to Natomas</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.natomasbuzz.com/2022/04/jury-convicts-man-of-killing-librarian/' rel='external nofollow ugc' class='url'>Jury Convicts Man of Killing Librarian | The Natomas Buzz</a></span> on <a href="https://www.natomasbuzz.com/2019/12/beloved-librarian-remembered-in-natomas/#comment-7421">Beloved Librarian Remembered in Natomas</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.natomasbuzz.com/2022/04/one-dead-after-shooting-in-south-natomas/' rel='external nofollow ugc' class='url'>One Dead After Shooting in South Natomas | The Natomas Buzz</a></span> on <a href="https://www.natomasbuzz.com/2022/04/two-dead-after-early-morning-shooting/#comment-7420">Two Dead After Early Morning Shooting</a></li><li class="recentcomments"><span class="comment-author-link">BKSacNative</span> on <a href="https://www.natomasbuzz.com/2022/04/two-dead-after-early-morning-shooting/#comment-7416">Two Dead After Early Morning Shooting</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.natomasbuzz.com/2022/04/two-dead-after-early-morning-shooting/' rel='external nofollow ugc' class='url'>Two Dead After Early Morning Shooting | The Natomas Buzz</a></span> on <a href="https://www.natomasbuzz.com/2021/05/one-dead-one-injured-in-natomas-shooting/#comment-7415">One Dead, One Injured in Natomas Shooting</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.natomasbuzz.com/2022/03/stacey-bastian-sworn-in-as-twin-rivers-trustee/' rel='external nofollow ugc' class='url'>Stacey Bastian Sworn in as Twin Rivers Trustee | The Natomas Buzz</a></span> on <a href="https://www.natomasbuzz.com/2022/01/twin-rivers-unified-mourns-the-death-of-trustee-bastian/#comment-7411">Twin Rivers Unified Mourns the Death of Trustee Bastian</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.natomasbuzz.com/2022/03/developer-to-submit-plans-for-frys-store-reuse/' rel='external nofollow ugc' class='url'>Developer to Submit Plans for Fry’s Store Reuse | The Natomas Buzz</a></span> on <a href="https://www.natomasbuzz.com/2020/12/frys-closure-in-natomas-appears-permanent/#comment-7410">Fry&#8217;s Closure in Natomas Appears Permanent</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.natomasbuzz.com/2022/03/developer-to-submit-plans-for-frys-store-reuse/' rel='external nofollow ugc' class='url'>Developer to Submit Plans for Fry’s Store Reuse | The Natomas Buzz</a></span> on <a href="https://www.natomasbuzz.com/2021/04/socal-developer-has-plans-for-frys-store/#comment-7408">SoCal Developer has Plans for Fry&#8217;s Store</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.natomasbuzz.com/2021/04/socal-developer-has-plans-for-frys-store/' rel='external nofollow ugc' class='url'>SoCal Developer has Plans for Fry’s Store | The Natomas Buzz</a></span> on <a href="https://www.natomasbuzz.com/2020/12/frys-closure-in-natomas-appears-permanent/#comment-7407">Fry&#8217;s Closure in Natomas Appears Permanent</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.natomasbuzz.com/2022/03/fans-say-goodbye-to-the-old-barn-in-natomas/' rel='external nofollow ugc' class='url'>Fans Say Goodbye to the Old Barn in Natomas | The Natomas Buzz</a></span> on <a href="https://www.natomasbuzz.com/2022/03/fans-share-their-favorite-arco-arena-memories/#comment-7404">Fans Share their Favorite Arco Arena Memories</a></li></ul></div></div> </div>
</div>
</div>
</div>
<script type="text/javascript">
	
		
			jQuery(document).ready(function($) {
				 $('#tabsWrapper').fadeIn();
			     $('#tabs').helloTabs({
					menuId: '#tabs-menu',
					contentId: '#tabs-content-inner',
										easing: "",
										effect: "slideDownSlideUp",
					speed: 500				 });
			});
		</script>
</div></div>
</div></div></div></div><div id="bottom-banner">
<div id="media_image-7" class="widget widget_media_image"><div class="widget-wrap"><img width="990" height="144" src="https://www.natomasbuzz.com/wp-content/uploads/2013/06/websitefooter.jpg" class="image wp-image-7458  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://www.natomasbuzz.com/wp-content/uploads/2013/06/websitefooter.jpg 990w, https://www.natomasbuzz.com/wp-content/uploads/2013/06/websitefooter-300x43.jpg 300w" sizes="(max-width: 990px) 100vw, 990px" /></div></div></div><div id="footer" class="footer"><div class="wrap"><div class="creds"><p>Copyright &copy; 2008-2022 The Natomas Buzz &middot; <a href="https://www.natomasbuzz.com/wp-login.php">Log in</a></p></div><div class="gototop"><p><a href="#wrap" rel="nofollow">Return to top of page</a></p></div></div></div></div>
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-includes/js/comment-reply.min.js?ver=148c2183e3f7a8eec23d2367ee517a32' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-includes/js/hoverIntent.min.js?ver=1.10.2' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10' id='superfish-js'></script>
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=2.10.1' id='superfish-args-js'></script>
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-content/themes/genesis/lib/js/menu/superfish.compat.min.js?ver=2.10.1' id='superfish-compat-js'></script>
<script type='text/javascript' src='https://www.natomasbuzz.com/wp-content/plugins/hello-tabs-widget-plugin/js/hello.tabs.1.0.js?ver=3.5.2'></script>
<link rel='stylesheet' id='hello_tabs_css-css' href='https://www.natomasbuzz.com/wp-content/plugins/hello-tabs-widget-plugin/css/helloTabs.css?ver=3.5.2' type='text/css' media='all' />

<script type="text/javascript">
window._qevents = window._qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

window._qevents.push({
qacct:"p-bHqc2sPQzy76_",
uid:"__INSERT_EMAIL_HERE__"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-bHqc2sPQzy76_.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>

</body>
</html>
